Actualización de MySQL / MariaDB | Documentación de cPanel y WHM

Actualización de MySQL / MariaDB

Válido para las versiones 100 hasta la última versión


Última modificación: 22 de septiembre de 2021

Visión general

Esta interfaz le permite administrar las actualizaciones de versiones de MySQL® o MariaDB® (por ejemplo, cuando actualiza de MySQL 5.7 a 8.0). Después de seleccionar su versión de MySQL o MariaDB, WHM mantiene actualizado automáticamente su motor de base de datos. Esto significa, por ejemplo, que cada vez que el proveedor lanza un nuevo parche para su versión de MySQL o MariaDB, WHM aplica automáticamente el parche a su instalación.

Advertencia:

  • Nosotros fuertemente Le recomendamos que haga una copia de seguridad de su base de datos antes de actualizar su base de datos o cambiar a MariaDB.

  • Esta función no admite degradaciones de versiones del motor de base de datos. Nosotros fuertemente le recomendamos que no intente degradar MySQL o MariaDB.

  • El sistema considera que MariaDB es una actualización de MySQL. Si cambia el motor de la base de datos a MariaDB, no poder volver a MySQL.

  • usted no poder actualice MySQL 8 a MariaDB 10.x debido a incompatibilidades entre estas versiones. Para obtener más información, lea Documentación de MariaDB. Sin embargo, los administradores del sistema pueden elegir MySQL o MariaDB durante el proceso de instalación de cPanel & WHM. Para obtener más información, lea nuestro Guía de instalación.

  • Si el Gobernador MySQL de CloudLinux ™ existe en su servidor, las actualizaciones de MySQL no trabajar a través de esta interfaz. Si desea eliminar MySQL Governor, lea CloudLinux’s Gobernador MySQL documentación e investiga cómo esto te afecta.

  • Hacemos no apoyar el uso de MySQL sha256_password complemento para MySQL 5.7, MySQL 8, MariaDB 10.2 o MariaDB 10.3.

  • los phpinfo El archivo puede mostrar una versión de MySQL diferente a la versión que seleccione.

    • La versión de API que ves en el phpinfo file es la API de MySQL incorporada que incluye PHP.

    • Si el buildapache La aplicación usa las bibliotecas y los encabezados de MySQL en el servidor mismo, y si cambia la versión de MySQL, Apache no puede funcionar correctamente. Debido a que cPanel & WHM actualiza los RPM de MySQL cada vez que Red Hat lanza actualizaciones, esto podría romper automáticamente miles de servidores en unas pocas horas. Por esta razón, cPanel, LLC siempre construye Apache y PHP con la -builtin opción.

  • Puede utilizar MySQL versión 5.7 u 8.0 en servidores de Amazon Relational Database ™ Service (RDS). Hacemos no admite MariaDB en servidores Amazon RDS.

Versiones disponibles

Están disponibles las siguientes versiones de MySQL:

Nota:

Si actualmente ejecuta MySQL 5.6 o anterior y desea actualizar a MySQL 8.0, debe debe primera actualización a MySQL 5.7.

Importante:

  • MySQL 8.0 es el solamente servicio de base de datos y versión que cPanel & WHM versión 100 admite para Ubuntu® 20.04.

  • cPanel & WHM versión 100 para Ubuntu 20.04 LTS es experimental software y lo hacemos no Recomendamos su uso en entornos de producción. Para obtener más información, lea nuestro cPanel y WHM versión 100 para Ubuntu 20.04 LTS documentación.

Están disponibles las siguientes versiones de MariaDB:

  • MariaDB 10.2

  • MariaDB 10.3

  • MariaDB 10.5

  • MariaDB 10.6

Advertencia:

  • En CloudLinux 6, MariaDB 10.5 y versiones posteriores solo están disponibles usando los paquetes MySQL Governor. Para obtener más información, lea el CloudLinux documentación.

Actualice o reinstale MySQL o MariaDB

Para actualizar o reinstalar la versión de MySQL o MariaDB de su servidor, realice los siguientes pasos:

  1. Seleccione la versión de MySQL o MariaDB que desea actualizar.

    Nota:

    Para reinstalar su base de datos, seleccione su versión actual de MySQL o MariaDB.

  2. Hacer clic Continuar. Aparecerá una nueva interfaz con mensajes de advertencia sobre el proceso de actualización.

    Nota:

    El sistema valida la /etc/my.cnf archivo durante la actualización.

  3. Si está actualizando su servidor de base de datos de MySQL versión 5.7 a 8, el Upgrade Checker a través de MySQLShell (opcional) aparecerá la sección. Esta utilidad comprueba si la actualización funcionará en el archivo de configuración de MySQL y en el motor de tablas. Para ejecutar el Comprobador de actualizaciones de MySQL utilidad, haga clic en Instalar y ejecutar Checker. Aparecerá una ventana de progreso y mostrará los resultados de la verificación de actualización.

    • Puede resolver cualquier problema que aparezca en los resultados y hacer clic en Volver a ejecutar el verificador para ejecutar el Comprobador de actualizaciones de MySQL utilidad de nuevo.
  4. Seleccione la casilla de verificación junto a cada advertencia para reconocer que conoce las posibles consecuencias de la actualización.

  5. Hacer clic Continuar.

  6. Seleccione el tipo de actualización que desea realizar:

  7. Hacer clic Continuar. Aparecerá la interfaz del proceso de actualización.

    • Seleccione o anule la selección de Salida de desplazamiento automático casilla de verificación para cambiar si la pantalla de salida se desplaza a medida que se ejecuta la actualización.

    • Si seleccionó el Actualización interactiva escriba en la pantalla anterior, la interfaz le pedirá que continúe con cada paso a medida que avanza la actualización. La interfaz también puede proporcionar instrucciones para tareas adicionales que es posible que deba completar antes de continuar con la actualización.

  8. Cuando finalice la actualización, la interfaz mostrará un mensaje. El mensaje dirá si la actualización se realizó correctamente o si existen errores que deberá solucionar para completar la actualización.

Registro de actualización de MySQL

El sistema almacena los archivos de registro de MySQL y MariaDB en el /var/cpanel/logs directorio. Los archivos de registro utilizan mysql_upgrade_log.YYYYMMDD-hhmmss Convención de nomenclatura con los siguientes designadores:

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *