Cómo limitar las versiones PHP disponibles en MultiPHP Manager

Cómo limitar las versiones PHP disponibles en MultiPHP Manager


Última modificación: 28 de septiembre de 2020

Visión general

En cPanel & WHM versión 70, agregamos la capacidad de mostrar solo versiones específicas de PHP a un usuario en sistemas que ejecutan EasyApache 4 Es posible que desee limitar las versiones visibles de PHP de una cuenta por una variedad de razones, incluso para limitar el acceso a versiones heredadas de PHP o para evitar una actualización anticipada a una versión más nueva de PHP.

Nota:

Usted puede solamente utilice esta función en sistemas que ejecuten EasyApache 4.

Importante:

Un usuario puede omitir las restricciones de la versión de PHP si establece la versión de PHP manualmente en un .htaccess expediente. Esta característica solo evita la selección de una versión de PHP en cPanel’s Administrador de MultiPHP interfaz (cPanel >> Inicio >> Software >> MultiPHP Manager). Las recompensas de errores hacen no solicitar.

Cómo configurar restricciones

Las limitaciones en las versiones de PHP de una cuenta requieren una lista de funciones, un paquete de cuenta y versiones de PHP instaladas. Cuando instala una versión de PHP en su sistema, todas las cuentas pueden acceder a la versión de forma predeterminada. usted debe agregue una limitación si no desea que la versión sea visible para todos los usuarios.

Para crear limitaciones para versiones específicas de PHP, realice los siguientes pasos:

  1. Cree una nueva lista de funciones o modifique una existente en WHM Administrador de funciones interfaz (WHM >> Inicio >> Paquetes >> Administrador de funciones).

  2. Anule la selección de las versiones de PHP a las que desee limitar la visibilidad de sus usuarios.

    Nota:

    • Cuando instala una nueva versión de PHP en su servidor, todos los usuarios pueden acceder a ella de forma predeterminada.
    • Las limitaciones se aplican a todas las versiones de PHP disponibles en EasyApache 4, incluidos los paquetes PHP personalizados.
  3. Cree un nuevo paquete en WHM Agregar un paquete interfaz (WHM >> Inicio >> Paquetes >> Agregar un paquete), o modificar uno existente en WHM Editar un paquete interfaz (WHM >> Inicio >> Paquetes >> Editar un paquete).

  4. Asigne la lista de funciones a su paquete seleccionado.

  5. Asigne el paquete a los usuarios para los que desea limitar PHP en WHM Modificar una cuenta interfaz (WHM >> Inicio >> Funciones de cuenta >> Modificar una cuenta).

Limitaciones

Si establece limitaciones de PHP para la cuenta de un usuario, el usuario no poder seleccione las versiones limitadas de PHP en cPanel’s Administrador de MultiPHP interfaz (cPanel >> Inicio >> Software >> MultiPHP Manager). Un administrador del sistema aún puede asignar un usuario a una versión limitada de PHP. Esto permite a un usuario permanecer en una versión heredada de PHP, pero no volver a esa versión a través de la interfaz si se cambia a una versión diferente de PHP.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *