Mejorar bloqueadores | Documentación de cPanel y WHM

Mejorar bloqueadores


Última modificación: 27 de septiembre de 2021

Visión general

Cuando actualiza a una versión más reciente de cPanel & WHM o instala cPanel & WHM en un servidor nuevo, el sistema verifica la compatibilidad con la versión de cPanel & WHM que desea instalar. Bloqueadores son condiciones que no permiten el proceso de actualización de cPanel & WHM (upcp) para instalar o actualizar a una versión en particular.

Advertencia:

Antes de actualizar la versión de cPanel & WHM en un servidor, fuertemente le recomendamos que restaure la administración de cPanel & WHM de todos los destinos FTP en su servidor. Si el objetivo de FTP RPM se establece en unmanaged en un servidor que desea actualizar, puede encontrar problemas en la interfaz de cPanel. Para obtener más información, lea nuestro Cómo configurar o desarmar la administración de RPM documentación.

Antes de comenzar una nueva instalación, lea nuestro Guía de instalación documentación. Los procesos de instalación y actualización de cPanel & WHM requieren por lo menos 5 GB de espacio en disco en el /usr/local/cpanel directorio.

Actualizaciones en múltiples versiones principales

Advertencia:

  • Después de actualizar a una nueva versión principal de cPanel & WHM, no poder degradar a una versión principal anterior.

  • Después de actualizar a la versión 78 de cPanel & WHM, el sistema se actualizará para usar el nivel de lanzamiento de Soporte a largo plazo (LTS). El sistema solo realiza este cambio si el CPANEL valor en el /etc/cpupdate.conf el archivo es 11.78 o 78o si representa un valor no válido (por ejemplo, 123.45.lug.gage).

  • Si está actualizando desde una versión muy antigua de cPanel & WHM, es posible que experimente problemas.

    • Para resolver este problema, actualice manualmente a una versión intermedia utilizando el /etc/cpupdate.conf expediente. Luego, puede pasar a la versión de destino final.
    • Si necesita ayuda, comuníquese con Soporte técnico de cPanel.

Si ejecuta una actualización que incluye varias actualizaciones de versiones principales de cPanel y WHM, el proceso de actualización de cPanel y WHM (upcp) actualizará su servidor a cada versión intermedia. El proceso de actualización realiza comprobaciones de compatibilidad para cada versión intermedia antes de cada actualización.

Ejemplo

Por ejemplo, después de que un administrador del sistema ejecuta una actualización en un servidor que ejecuta cPanel & WHM versión 80, y la versión de destino es cPanel & WHM versión 86, el proceso de actualización de cPanel & WHM (upcp) realiza las siguientes acciones:

  1. El proceso de actualización detecta que el sistema debe actualizarse primero a cPanel & WHM versión 82.

  2. El proceso de actualización realiza comprobaciones de compatibilidad para la actualización a cPanel & WHM versión 82.

    • Si el sistema es compatible, el proceso de actualización actualiza cPanel & WHM a la versión 82.
    • Si el sistema es no compatible, el proceso de actualización envía una lista de los problemas de compatibilidad al administrador del sistema y el servidor permanece en cPanel & WHM versión 80.
  3. Una vez que se completa la actualización a la versión 82, el proceso de actualización realiza verificaciones de compatibilidad para la actualización a cPanel & WHM versión 84.

    • Si el sistema es compatible, el proceso de actualización actualiza cPanel & WHM a la versión 84.
    • Si el sistema es no compatible, el proceso de actualización envía una lista de los problemas de compatibilidad al administrador del sistema, y ​​el servidor permanece en cPanel & WHM versión 82.
  4. Una vez que se completa la actualización a la versión 84, el proceso de actualización realiza verificaciones de compatibilidad para la actualización a cPanel & WHM versión 86.

    • Si el sistema es compatible, el proceso de actualización actualiza cPanel & WHM a la versión 86.
    • Si el sistema es no compatible, el proceso de actualización envía una lista de los problemas de compatibilidad al administrador del sistema y el servidor permanece en cPanel & WHM versión 84.

Comprobaciones del sistema y del software

Los procesos de actualización e instalación de cPanel & WHM realizan dos tipos de verificación:

  • Estándar – Las comprobaciones estándar se aplican a todas las instalaciones y actualizaciones.

  • Específico de la versión – Las comprobaciones específicas de la versión son requisitos específicos para la versión de cPanel & WHM que está instalando o actualizando.

Si cPanel & WHM encuentra un problema de compatibilidad que bloquea el proceso de instalación o actualización, ocurren los siguientes eventos:

  1. Si inició una actualización, el sistema permanece en la última versión compatible conocida. Si inició una nueva instalación de cPanel & WHM, el sistema permanece en su estado de preinstalación.

  2. cPanel & WHM envía una lista de los bloqueadores al administrador del sistema.

  3. Se cierra el proceso de instalación o actualización.

Comprobaciones de actualización estándar

Cuando ejecuta una actualización de cPanel & WHM a cualquier versión, el proceso de actualización realiza las siguientes comprobaciones estándar:

Archivos de licencia

usted no poder actualice cPanel y WHM si se cumple alguna de las siguientes condiciones:

  • El proceso de actualización de cPanel & WHM no puede encontrar un archivo de licencia de cPanel & WHM válido.

    • Sin el archivo de licencia, cPanel & WHM no puede funcionar correctamente y bloqueará todas las actualizaciones.
    • usted debe compre una licencia válida para actualizar, degradar o usar cPanel & WHM.
  • El proceso de actualización de cPanel & WHM no puede leer su archivo de licencia de cPanel & WHM.

  • La licencia de su servidor ya no es elegible para actualizaciones.

Si tiene dificultades con su licencia, contacta con nuestro departamento de atención al cliente.

Sistemas de archivos de solo lectura

Para garantizar que el sistema pueda escribir archivos en directorios críticos, el proceso de actualización de cPanel & WHM fallará si los siguientes sistemas de archivos de directorios existen en un estado de solo lectura:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
/etc
/var
/var/lib/rpm
/var/cpanel
/usr/local
/usr/local/cpanel
/usr/local/bin
/usr/bin
/tmp
/var/tmp

Integridad de la base de datos RPM

A partir de la versión 11.36 de cPanel & WHM, el proceso de actualización verifica la integridad de la base de datos RPM.

  • Para verificar la integridad de la base de datos RPM, el proceso de actualización instala y desinstala un RPM de prueba.

  • El proceso de actualización intenta reparar el problema, pero si no puede reparar la base de datos RPM, el intento de actualización falla.

Requisitos de versión y bloqueadores

Advertencia:

Si un bloqueador para la versión de cPanel & WHM a la que desea actualizar está presente en su sistema cuando inicia el proceso de actualización de cPanel & WHM, el proceso de actualización fallar.

Seleccione una versión de cPanel & WHM a continuación para ver los requisitos de instalación y los bloqueadores de actualización:

cPanel y WHM versión 88

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Amazon Linux 1

Servidores cPanel y WHM existentes que utilizan el sistema operativo Amazon Linux 1 no poder actualice de cPanel & WHM versión 86 a 88.

CentOS 6 y Red Hat Enterprise Linux (RHEL) 6

Servidores cPanel y WHM existentes que utilizan el sistema operativo CentOS 6 y Red Hat® Enterprise Linux® (RHEL) 6 no poder actualice de cPanel & WHM versión 86 a 88. Para obtener más información sobre nuestra desaprobación de CentOS 6, lea nuestro ¡CentOS 6, CloudLinux 6 OS y usted! entrada en el blog.

MySQL 5.5.
  • Si desea actualizar un servidor con MySQL 5.5 en cPanel & WHM versión 86, debe debe omita las versiones 88 y 90 de cPanel y WHM y actualice a la versión 92.
  • Actualice su versión de MySQL en WHM’s Actualización de MySQL / MariaDB interfaz (WHM >> Inicio >> Software >> Actualización MariaDB / MySQL).

cPanel y WHM versión 86

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Amazon Linux 1

Servidores que utilizan el sistema operativo Amazon Linux 1 no poder instale cPanel y WHM.

cPanel y WHM versión 80

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
  • MySQL® 5.6 y posterior, o cualquier versión de MariaDB®.
  • Al menos 360.000 inodos disponibles en el sistema de archivos de destino.
Mejorar bloqueadores
  • MySQL 5.5.

    • usted debe actualice a MySQL versión 5.6 o superior, o cualquier versión de MariaDB, antes de que pueda actualizar su servidor cPanel & WHM.
    • Actualice su versión de MySQL en WHM’s Actualización de MySQL / MariaDB interfaz (WHM >> Inicio >> Software >> Actualización MariaDB / MySQL).
  • Remoto MySQL 5.6 o más reciente.

    • usted debe actualice cualquier servidor de base de datos remoto a MySQL versión 5.6 o superior, o cualquier versión de MariaDB, antes de que pueda actualizar su servidor cPanel & WHM.
    • Verifique los perfiles MySQL de su base de datos remota en WHM Administrar perfiles de MySQL interfaz (WHM >> Inicio >> Servicios SQL >> Administrar perfiles MySQL).
  • Menos de 360.000 inodos disponibles.

cPanel y WHM versión 78

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
  • EasyApache 4.
  • LiteSpeed ​​versión 5.3.6 o posterior.
Mejorar bloqueadores

cPanel y WHM versión 68

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
Mejorar bloqueadores
  • los ea-apache24-config-runtimepackage versión 1.0-112 y anteriores.

  • LiteSpeed ​​versión 5.2.1 build 1 y anteriores.

    • Si LiteSpeed ​​existe en su servidor, debe actualice a LiteSpeed ​​versión 5.2.1 build 2 o posterior antes de actualiza a cPanel & WHM versión 68. De lo contrario, los sitios web no proporcionar toda la cadena de certificados y los navegadores pueden mostrar un error de SSL.
    • Ver el /usr/local/lsws/autoupdate/build archivo para verificar la información de la versión de LiteSpeed.
    • Para obtener más información sobre cómo actualizar LiteSpeed, lea LiteSpeed’s Complemento cPanel documentación.

Nota:

Si su servidor lo hace no contener el /usr/local/lsws/ directory, Es probable que LiteSpeed ​​no exista en su servidor.

cPanel y WHM versión 66

No existen requisitos de instalación específicos de la versión o bloqueadores de actualización para esta versión.

Nota:

Una vez finalizada la actualización a cPanel & WHM versión 66, los usuarios de WHM en una sesión activa debe actualizar las ventanas de su navegador. Hasta que lo hagan, es posible que vean marcos adicionales dentro de la interfaz WHM en cada carga de página.

cPanel y WHM versión 62

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
  • MySQL® versión 5.5 y posteriores.
Mejorar bloqueadores
  • MySQL versión 5.1 y anteriores.
    • usted debe actualice al menos a la versión 5.5 de MySQL antes de poder actualizar su servidor cPanel & WHM.
    • Actualice su versión de MySQL en WHM’s Actualización de MySQL o MariaDB interfaz (WHM >> Inicio >> Software >> Actualización MariaDB / MySQL).

cPanel y WHM versión 60

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
  • Soporte SNI.
    • Tu servidor debe admite SNI (por ejemplo, Apache (httpd) 2.2.12, Litetspeed 4.1 u Openlitespeed 1.4.12 o superior).
    • Utilice WHM EasyApache 4 interfaz (WHM >> Inicio >> Software >> EasyApache) para actualizar su servidor web.
Mejorar bloqueadores
  • Apache (httpd) 2.2.11 o anterior.

cPanel y WHM versión 58

Esta versión incluye los siguientes requisitos de instalación y bloqueadores de actualización:

Requerimientos de instalación
Mejorar bloqueadores
  • CentOS 5, RHEL 5 y CloudLinux 5.

    • Si su servidor ejecuta CentOS, …

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *