Requisitos de instalación de Ruby heredado | Documentación de cPanel y WHM

Requisitos de instalación de Ruby heredado


Última modificación: 22 de septiembre de 2021

Visión general

Advertencia:

Dejamos de utilizar la base de código Ruby heredada en cPanel & WHM versión 66. No admitiremos ninguna aplicación que cree con las siguientes interfaces:

  • cPanel Ruby on Rails interfaz (cPanel >> Inicio >> Software >> Ruby on Rails).

  • cPanel RubyGems interfaz (cPanel >> Inicio >> Software >> RubyGems).

  • los Instalador de Ruby Gem característica en WHM’s Instaladores de módulos interfaz (WHM >> Inicio >> Software >> Instaladores de módulos).

Para instalar Ruby y crear aplicaciones web Ruby en cPanel & WHM versión 66 y posteriores, siga las instrucciones en nuestro Cómo crear aplicaciones web Ruby documentación.

Antes de instalar Ruby en cPanel & WHM versión 64 y anteriores, asegúrese de cumplir con los siguientes requisitos de instalación:

Sistema operativo

Su servidor debe ejecutar CentOS 6 o 7, Red Hat® Enterprise Linux® (RHEL) 6 o 7, o CloudLinux ™ 6 o 7.

Nota:

Actualmente no admitimos instalaciones de Ruby on Rails en servidores CentOS 7 u 8, AlmaLinux OS 8, CloudLinux 7 u 8 o RHEL 7.

Permisos

usted debe poseer root-nivel de acceso en el servidor.

Mmm

La instalación de yum de su servidor debe funcionar correctamente.

Prueba tu configuración

Para probar su configuración de YUM, inicie sesión en su servidor a través de SSH como usuario root y ejecute el siguiente comando:

Si no ve ningún error después de ejecutar este comando, su configuración de YUM funciona correctamente.

El resultado de este comando debe parecerse al siguiente ejemplo:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
Setting up repositories
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================|  951 B    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  83 kB    00:00
sqlite cache needs updating, reading in metadata
update    : ################################################## 287/287
Excluding Packages in global exclude list
Finished

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *